Voice & Video Calling (North America) Maintenance
Scheduled for October 30, 2025 at 12:30 PM – 1:19 PM
Affects
North America (US)
Under maintenance from 12:30 PM to 1:19 PM
Voice & Video Calling
Under maintenance from 12:30 PM to 1:19 PM
- Completed October 30, 2025 at 1:19 PM
- Completed - October 30, 2025 at 1:19 PM- Maintenance has completed successfully. 
 
- In progress October 30, 2025 at 12:30 PM
- In progress - October 30, 2025 at 12:30 PM- Maintenance is now in progress 
 
- Planned October 30, 2025 at 12:30 PM
- Planned - October 30, 2025 at 12:30 PM- We will be performing scheduled infrastructure maintenance to enhance the security and performance of our services. - No service downtime or degradation is expected — your access and functionality will remain fully available throughout the maintenance window. 
- What to expect: - Continuous service availability with no disruption 
- Proactive health checks and real-time monitoring by our operations team 
- A confirmation notification once the maintenance is complete 
 - This maintenance is part of our ongoing commitment to providing a secure, reliable, and high-performance service. - Thank you for your continued trust in CometChat.